eStore Security Update

I have just been advised by Volusion, the ISP that supports and hosts the AHS estore, that they are upgrading the TLS security all such websites by June 30th 2015.

See here for full details.

What does it mean for you, our customer.  You will need to either upgrade your browser (e.g. Internet Explorer 11), or update settings in IE 10 or lower if you don’t want to see an unexpected security error message during checkout.  Similar updates are probably needed if you use Chrome, Modzilla, FireFox, or some other browser.

This entry was posted in Site Announcements and tagged , . Bookmark the permalink.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s